Greentram Software Support Forums

Greentram Software Support Forums (
-   Installation issues (
-   -   using programs in linux (

motorphotos 25th February 2014 04:12 PM

using programs in linux
having got frustrated with my laptop ended up re formatting hard drive and installed zorin os6 which came with wine preinstalled

loaded superbeam no problem and it all seems to work

have you had any reports of problems running programs in Linux based OS



Tony Bryer 25th February 2014 06:50 PM

Re: using programs in linux
A number of our users run our programs on Macs; yours is the first report of using Linux - thanks for the feedback

motorphotos 26th February 2014 12:55 PM

Re: using programs in linux
Hi Tony

I tried Linux mint which had trouble generally with integrating windows programs with WINE

I think as zorin os has WINE built in it I think it integrates better

The only problems I have had are that drivers etc work in windows and even though the programs run they get a bit tied up for example they don't find the wireless card in my laptop even though it works with google chrome so its there and installing printer drivers are not as simple as in windows


motorphotos 15th June 2015 07:51 PM

Re: using programs in linux
Latest version of Linux mint 17 cinnamon has wine built in finds the install from cd once I told it to use wine and after putting in all the activation info programs install and creates icons

Problem is that they do not run - so for time being given up trying to run in linux as I prefer mint to zorin so might even just buy laptop with windows just to run programs when out and about

Tony Bryer 15th June 2015 08:36 PM

Re: using programs in linux
Do you get any error messages or is just that the programs don't run? For quick and dirty beam checks away from base we're just rolling out our new cloud app which will run in any browser. More at

motorphotos 18th June 2015 09:28 AM

Re: using programs in linux
Hi Tony

No error messages you just click on the icon and nothing happens - the programs don't run when you find for example sb4.exe either so I think its more to do with the way WINE is dealing with the windows interface

I have no trouble running ms word or excel so I suppose WINE was written for more 'standard' windows programs rather than anything else not that I would need to run these programs as mint comes with the office libre suit preloaded which does everything ms office does and in the same formats etc it even has libre CAD which is a fully functioning 2d CAD package

I suppose Linux is a bit different to windows as it has various variants like Ubuntu, debian etc

never mind it was just a thought as I had an old sony viao with a 10 inch screen knocking about that had a very corrupt and slow version of windows on it (takes about 10mins to load) as opposed to mint which loads in about 30 secs



motorphotos 14th July 2015 01:17 PM

Re: using programs in linux
re installed mint 17.2 (these Linux distros are so easy to install its quick to change versions in about 5 mins and you can even run a distro from the cd/usb stick to see if it suits before installing)

I cannot get WINE (the Linux windows emulator) to load superbeam, prosteel or eurobeam no error messages just the little egg timer thing which spins around for a while then goes so at the moment I think I am right in saying these will not run in Linux (certainly not MINT or Zorin) but the calculator runs OK

Went to Staples and bought I laptop running windows 8

IT was worth a try and if anyone else has tried and succeeded please let me know


Tony Bryer 14th July 2015 01:33 PM

Re: using programs in linux
Thanks for the feedback, even if unsuccessful. You might try downloading and installing one of the demos off the website - they don't include the printing and PDF generation code which might be the stumbling block. If you still have problems, I'd be suspecting the script processing code - though as this, like the PDF generation library, comes from a third party we're not in a position to change it.

motorphotos 17th July 2015 07:45 AM

Re: using programs in linux
Hi Tony

Quick update installed the demo and it runs ok so it is as you suspected



motorphotos 1st September 2017 08:52 AM

Re: using programs in linux
Hi Tony

In my quest to bin windows (especially as there is talk of making it subscription like office 365) I have been playing around with alternative OS

I have now installed Linux MINT 18.2 Cinnamon which comes preloaded with Libre office (MS Office Equiv) which also has libre CAD (sort of like autocad but slightly different)

I have tried Zorin and this was a complete no go

I then installed WINE 1.8 (the windows emulator which was a bit of a faff to be honest but got it loaded) I also installed playonlinux which is a front end to wine makes installation of windows apps easier apparently - but don't need this to install the programs

Using the .exe files that were used to keep the programs up to date I put these on a usb key

Clicking on the .exe file runs the file and installs the programs through WINE
and then the process is the same as for windows

They install OK and run however if you click on the create desktop icon in the installation process you get a .lnk icon as well as an actual icon for the program so I am assuming that the .lnk is the link back to the main program in windows but the installation process also seems to put the main programme .exe on the desktop so the .lnk is redundant and does not work anyway so I just deleted the .lnk bit

The programs run as they should and all seem to work OK

The only issue is when you go to the drop down menus at the top they drop down as a black rectangle until you run the cursor down them and then the writing appears - not too much problem and this may be the graphics side of things

So I think I have cracked it for the time being so will continue to play around with it and give it a good test before I finally take the plunge and reformat my hard drive and ditch windows - you can have both OS on the same machine so when you start you get a screen that asks which OS you want to load but I found that when you do this the files etc need to be loaded twice on the hard drive one for each OS so I don't recommend this

I will let you know how I get on



All times are GMT. The time now is 07:15 AM.

Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2011 Greentram Software Pty Ltd, Melbourne, Australia